Forgejo Throttling

Incident Report for Ryubing

Update

The cause of this issue seems to be our webserver: Caddy. While Caddy is amazing for small to medium-sized websites, it's evident that something in the webserver level is causing insane slowdowns.

The only explanation for shared bad loading times between a bunch of services that all use the same reverse proxy is likely the reverse proxy.

We are looking into replacements that can handle the crazy load we are receiving better.
Posted May 02, 2026 - 22:46 UTC

Identified

We've set our Forgejo instance to sign-ins only to drastically lower the incoming traffic while we work with our service provider on a solution. Please do not spam our socials about the outage. Thank you again for all the support, we'll be back soon.
Posted Apr 19, 2026 - 18:13 UTC

Monitoring

We've implemented a solution and are monitoring for potential problems.
Posted Apr 19, 2026 - 03:23 UTC

Identified

Thank you all for the support! You're killing our server!

Seriously though, we've identified that the issue is related to bandwidth pressure and are working on a solution.
Posted Apr 18, 2026 - 20:46 UTC

Investigating

We are currently investigating this issue. While we investigate, the server will block connections that do not belong to administrators.
Posted Apr 18, 2026 - 20:13 UTC
This incident affects: Forgejo Instance, Update Server, and Legacy GitLab Instance.